Spanish Virtual Observatory

a

Discovery of Brown Dwarfs mining the 2MASS and SDSS databases

 

LAST UPDATE 16/11/2015 17:00h

Case 1: Discovery of Brown Dwarfs mining the 2MASS and SDSS databases

  • VO-Tools: ALADIN, TOPCAT
  • Scientific background: Brown dwarfs are objects occupying the gap between the least massive stars and the most massive planets. They are intrinsically faint objects so their detection is not straighforward and, in fact, was almost impossible until the advent of global surveys at deep optical and near-infrared bands like SDSS, 2MASS or DENIS among others.

We propose here to mine the 2MASS-PSC and SDSS-DR9 databases to identify T-type brown dwarfs through an appropriate combination of colours in the optical and the infra-red, an approach that perfectly fits into the Virtual Observatory.

  • Workflow:

In this use case, we will explore different ways to do the same tasks (cross-match, sources selection, filtering,...) with different VO tools.

  • First flow (Aladin): Aladin is used to
  • Launch Aladin: Open a terminal and type: java -jar Aladin.jar &
  • Search 2MASS-PSC and SDSS-DR9 sources around RA:08h 30m DEC:01d 30m with a 14 arcmin. radius.
  • File --> Open --> Surveys
  • Write 08:30 01:30 in the "Target" box
  • Click on the 2MASS-PSC catalogue. "2MASS-PSC" will appear in the "Survey" box.
  • Click on "Submit". Aladin will load the 2MASS-PSC plane with 683 sources.
  • Repeat the same steps for the SDSS-DR9 catalogue. A new plane will be loaded with 12404 sources.
  • Find common sources in 2MASS-PSC and SDSS-DR9 catalogues.
    • Catalog --> Cross match objects (or click on the "Cross" button on the right panel of Aladin main window).
    • First catalogue: 2MASS-PSC. Second catalogue: SDSS-DR9.
    • Default threshold (4 arcsec) and bestmatch option
    • Click on "Perform cross-match". A new plane ("X-match") with 679 sources will be loaded.
  • Select points sources using the SDSS flag (cl=6)
    • Hide (mouse right button) the 2MASS-PSC and the SDSS-DR9 planes
    • Click on the "Xmatch" plane
    • Catalogue --> Create a filter (or click on the "Filter" button on the right panel of Aladin main window).
    • Advanced mode --> Columns --> Columns in loaded catalogue. Select the "cl_tab2" column from the Xmatch catalogue
    • Complete the filter condition. It should be ${cl_tab2}=6 {draw}
    • Click on "Apply". Then click on "Export" to create a new plane with the filtered sources.
    • A new plane "Filter.src" will be loaded in the Aladin main window. It contains 649 sources.
  • Select sources with no detection in the u,g SDSS filters (u > 22.0 && g >22.2). Brown dwarfs are cool objects so they are not detected in the blue SDSS filter.
    • Hide the Xmatch plane
    • Click on the "Filter.src" plane
    • Repeat the same steps as in the previous filter. The filter condition should be: {umag_tab2}>22.0 && {gmag_tab2}>22.2 {draw}
    • A new plane "Filter.src-1" will be loaded in the Aladin main window. It contains 6 sources.
  • Select sources following the brown dwarf criteria provided by Burgasser et al. (2000, Apj, 531, L57).(J-H)<0.3 && (H-K)<0.3 :
    • Hide the Filter.src plane
    • Click on the "Filter.src-1" plane
    • Now you can either use arithmetic operations between columns directly in the filter syntax, or you can create new columns (Catalog --> Add a new column) that are an arithmetic combination of 2 columns (e.g. Jmag - Hmag)
    • The filter condition should be: ${Jmag_tab1}-${Hmag_tab1}<0.3 && ${Hmag_tab1}-${Kmag_tab1}<0.3 {draw}
    • A new plane "Filter.src-2" will be loaded in the Aladin main window. It contains 1 source. (RA:127.703265deg; DEC:1.475320deg).

 

  • We can now use Simbad to confirm the brown dwarf nature of this object
    • File --> Open --> Simbad
    • Click on "Grab coord" and click on the source. The coordinates of the source will be copied to the "Target (ICRS, Name)" box.
    • Select a 30arcsec radius. Click "Submit"
    • A new plane "Simbad" will be loaded in the Aladin main window.
    • Click on the "Simbad" plane. Select all sources in this plane (mouse right button). A table containing one row will appear at the bottom of the Aladin main window.
    • Click on the Main ID. Simbad will be launched in your browser with information on the source.

  • Second flow (TOPCAT): TOPCAT is used to
  • Search 2MASS-PSC and SDSS-DR9 sources around RA:08h 30m DEC:01d 30m with a 14 arcmin. radius.
  • In the main window: VO--> Vizier Catalogue Service.
  • Cone selection: Give the coordinates and a radius of 14'.
  • Catalogue selection: Surveys --> 2MASS PSC. --> OK
  • Repeat previous steps for SDSS-DR9.
  • Alternatively, you could load the 2MASS and SDSS DR9 catalogs in Aladin and broadcast the planes to TOPCAT using SAMP.
  • Find common sources in 2MASS-PSC and SDSS-DR9 catalogues.
    • Joins --> Pair Match
    • In the "Match Table" windows
      • Max error: 4 arcsec
      • Table1: II_246_out (2MASS_PSC). RA/Dec columns: RAJ2000, DEJ2000
      • Table2: V_139_sdss9 (SDSS-DR9). RA/Dec columns: RAJ2000, DEJ2000
      • A new plane "match(1,2)" with 679 sources is loaded.
  •  Select points sources using the SDSS flag (cl=6) 
    • View --> Row subsets
    • In the "Row subsets" window: Subsets --> New subset
    • Fil in the "Subset name" box (for instance, filt1)
    • Expression: cl==6. Click OK.
    • In the TOPCAT Main Window select "filt1" in the "Row Subset" box. 649 sources are selected.
  • Select sources with no detection in the u,g SDSS filters (u > 22.0  & g >22.2). Brown dwarfs are cool objects so they are not detected in the blue SDSS filter. 
    • Update the selection criteria adding "&& umag>22.0 && gmag>22.2". 6 sources are selected.
  • Select sources following the brown dwarf criteria provided by Burgasser et al. (2000, Apj, 531, L57).(J-H)<0.3 & (H-K)<0.3.
    • Update the selection criteria adding "&& (Jmag-Hmag)<0.3 && (Hmag-Kmag)<0.3". 1 source is selected. RA:127.703265deg; DEC:1.475320deg.
    • As in the previous flow, alternatively, you can create new columns in the catalog. For this, go to the main TOPCAT window -> Views --> Column info. In the "Table columns" window: Columns -> New synthetic column


  • Third flow (Advanced scripting / ALADIN): ALADIN has a script mode to build a list of commands to be processed (Tool > Macro Controller). The workflow can be executed automatically for a list of targets.
  • Open the Tool > Macro Controller in Aladin
  • SCRIPT


2mass = get VizieR(2MASS-PSC) $1 $2 14'
sync
sdss = get VizieR(SDSS-DR9) $1 $2 14'
sync
2massdss= xmatch 2mass sdss 4 bestmatch
sync
hide 2mass
sync
hide sdss
sync
filter stars_SDSS { ${cl_tab2}==6 {draw} }
sync
select 2massdss
sync
cplane stars
sync
hide 2massdss
sync
hide stars_SDSS
sync
filter candidates {${umag_tab2}>22.0 && ${gmag_tab2}>22.2 && ${Jmag_tab1}-${Hmag_tab1}<0.3 && ${Hmag_tab1}-${Kmag_tab1}<0.3 {draw}}
sync
select stars
sync
cplane candidates
sync
hide stars
sync

  •  The param file with the coordinates must have this format
  •  # RA DEC
  • 08:30:00,+01:30:00
  • More information can be found at: "Help > Help on script commands"

  • Fourth flow (Advanced scripting / TOPCAT): we use STILTS to create an script.
  • java -jar stilts.jar tskymatch2 ifmt1=votable in1=2mass.xml ifmt2=votable in2=sdssdr9.xml ra1=RAJ2000 dec1=DEJ2000 ra2=RAJ2000 dec2=DEJ2000 error=4 find=best join=1and2 ofmt=votable out=cross-match.xml
  • java -jar stilts.jar tpipe ifmt=votable in=cross-match.xml cmd='select "cl == 6"' ofmt=votable out=filter1.xml
  • java -jar stilts.jar tpipe ifmt=votable in=filter1.xml cmd='select " umag > 22.0 & gmag > 22.2 "' ofmt=votable out=filter2.xml
  • java -jar stilts.jar tpipe ifmt=votable in=filter2.xml cmd='addcol Jmag-Hmag "(Jmag-Hmag)"' ofmt=votable out=addcol1.xml
  • java -jar stilts.jar tpipe ifmt=votable in=addcol1.xml cmd='addcol Hmag-Kmag "(Hmag-Kmag)"' ofmt=votable out=addcol2.xml
  • java -jar stilts.jar tpipe ifmt=votable in=addcol2.xml cmd='select "Jmag-Hmag < 0.3"' ofmt=votable out=filter3.xml
  • java -jar stilts.jar tpipe ifmt=votable in=filter3.xml cmd='select "Hmag-Kmag < 0.3"' ofmt=votable out=candidates.xml
  • java -jar stilts.jar tcopy ifmt=votable in=candidates.xml ofmt=ascii out=candidates.dat
© CAB 2020   (SVO Privacy Policy)