VOV. Aladin
NOTE: This tutorial is based on Aladin v10. The content here described should be compatible with
Aladin v11.
All VOV video and pdf tutorials are available here.
I) Science case: Discovery of Brown Dwarfs mining the 2MASS and databases with Aladin.


Scientific background: Brown dwarfs are objects occupying the gap between the least
massive stars and the most massive planets. They are intrinsically faint objects so their
detection is not straighforward and, in fact, was almost impossible until the advent of global
surveys at deep optical and near-infrared bands. We propose here to mine the 2MASS-PSC
and SDSS-DR12 databases to identify T-type brown dwarfs through an appropriate
combination of colours in the optical and the infrared, an approach that perfectly fits into the
Virtual Observatory.



Workflow: In this tutorial we will explore how to perform the download of data, cross- match
of catalogs, sources selection and filtering with Aladin Sky Atlas.
▪ Launch Aladin: Open a terminal and type: java -jar Aladin.jar &
•

Discovery: Search 2MASS-PSC and SDSS-DR12 sources around RA:08h 30m
DEC:01d 30m with a 14 arcmin radius.
◦ On top of the central panel, click “2MASS” just below the Command box. This
will load all the sky observed by 2MASS.
◦ On the left panel of the Aladin window, click on the select box located in the
bottom corner and type “2MASS”. The discovery tree will open and show the
available catalogs.
◦ Click in the “2MASS All-Sky Catalog of Point Sources” photometric catalog. A
new window will pop up.
◦ Write 08:30:00 +01:30:00 14’ in the empty box next to the Load button and
click on Load. Aladin will load in the main window the 2MASS plane with 683
sources (you can see the number of sources by placing the cursor on the
name of the plane in the right panel).
◦ Repeat the same steps for the SDSS-DR12 catalog. Select the SDSS-DR12
catalog in the V – Combined data folder. A new plane will be loaded with
12404 sources.
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•

Crossmatching: Find common sources in 2MASS-PSC and SDSS-DR12 catalogs.
◦ In the Aladin main window: Catalog –> Cross match objects.
◦ First catalog: 2MASS-PSC (CDS/II/246/out). Second catalog: SDSS-DR12
(CDS/V/147/sdss12). Default threshold (4 arcsec) and bestmatch option.
◦ Click on Perform cross-match. A new plane (“XMatch”) with 679 sources will
be loaded.

•

Filtering:
◦ In this step we will select point sources using the SDSS flag (class=6). "class"
is a column of the SDSS- DR12 catalog that provides information on the type
of object (3=galaxy, 6=star).
▪ Click on the “XMatch” plane. The name of the plane would appear
highlighted.
▪ In the Aladin main window: Catalog –> Create a filter (or click on the Filter
button on the right panel of Aladin main window) → Advanced mode –>
Columns –> Columns in loaded catalog. A new window (“Available
columns”) will pop up. Select the “class_tab2” column from the Xmatch
plane. The label of this column will be copied to the “Properties” window.
▪ Complete the filter condition. It should be ${class_tab2}=6 {draw}
▪ Click on Apply. Then click on Export to create a new plane with the
filtered sources.
▪ A new plane “Filter.src” will be loaded in the Aladin main window. It
contains 649 sources.
▪ If you wish you can modify the colour and/or the shape of the sources of
this new plane by doing the following:
•
•
•
•

Click on the "Filter.src" plane.
Click on the prop button on the right panel of Aladin main window. A
new window ("Properties") will pop up.
Select the color and /or shape you wish.
Click on Apply.

◦ Now, let's select sources with no detection in the u,g SDSS bands (u > 22.0
&& g >22.2, since brown dwarfs are cool objects not detected in the blue
SDSS bands) and sources fulfilling the brown dwarf criteria provided by
Burgasser et al. (2000, Apj, 531, L57): ((J-H)<0.3 && (H- K)<0.3).
▪ Click on the icons on the left of the names of the planes to hide them all
but “Filter.src”.
▪ Click on the “Filter.src” plane.
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▪ Repeat the same steps as in the previous filter. The filter condition now
should be:

•

•

${umag_tab2} > 22.0 && ${gmag_tab2} > 22.2 && ${Jmag_tab1} - $
{Hmag_tab1} < 0.3 && ${Hmag_tab1} - ${Kmag_tab1} < 0.3 {draw}

•

Click on Apply. Then click on Export to create a new plane with the
filtered sources. A new plane “Filter.src~1” will be loaded in the Aladin
main window. It should contain 1 source (RA_2MASS:127.703265deg;
DEC_2MASS:1.475320deg). NOTE: You will get information on the
source by clicking on it.

Analysis: We can now use Simbad to confirm the brown dwarf nature of this
object:
◦ Place the cursor on the source.
◦ After a few seconds a small window with basic information of the object will
appear. If it does not, click on the right mouse button and select Astronomical
object exploration (Simbad & VizieR).
◦ By clicking on the object name (in blue) a new tag will open in your browser
with the information available in Simbad for this particular object.

NOTE: Before running each of the following examples, it is convenient to remove all loaded catalogs
and images by clicking the right mouse button over any of the planes in the panel to the right in the
main window and selecting Delete all panels.
II) Other functionalities:


CDS-X match: This option is suitable when we want to cross-match a catalog of sources
with another VO catalog in different sky regions or when the region to load is too large, for
example.
▪ We will repeat the exercise described in the Discovery section of the science case
using this time the CDS-X match option.
•

Load 2MASS-PSC sources around RA:08h 30m DEC:01d 30m with a 14 arcmin
radius as described above. For clarity, the steps are repeated here:
◦ On top of the central panel, click “2MASS” just below the Command box. This
will load all the sky observed by 2MASS.
◦ On the left panel of the Aladin window, click on the select box located in the
bottom corner and type “2MASS”. The discovery tree will open and show the
available catalogs.
◦ Click in the “2MASS All-Sky Catalog of Point Sources” photometric catalog. A
new window will pop up.
◦ Write 08:30:00 +01:30:00 14’ in the empty box next to the Load button and
click on Load. Aladin will load in the main window the 2MASS plane with 683
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sources (you can see the number of sources by placing the cursor on the
name of the plane in the right panel).
•

Cross-match the 2MASS catalog loaded in the previous step with SDSS-DR12 in
an alternative way:
◦ On the left panel of the Aladin window, click on the select box located in the
bottom corner and type “SDSS DR12”. The discovery tree will open and show
the available catalogs.
◦ Select the SDSS-DR12 catalog in the V – Combined data folder. A new
window will pop up.
◦ Select by CDS-X match and click Load. A new plane will be loaded in the
main window with 679 sources resulting from the cross-match between
2MASS and SDSS-DR12. Note: In the pop up window, the previous to the last
symbol on the bottom right corner of the SDSS-DR12 window opens a new
window where the configuration parameters of the cross-match can be
changed.



MOC (Multi-object coverage). Used to describe sky regions (e.g. footprints) and provides a
very fast mechanism to perform operations (union, intersection,...) between them.
▪ How to obtain the sky coverage of SDSS DR12:
◦ On the left panel of the Aladin window, click on the select box located in the
bottom corner and type “SDSS DR12”. The discovery tree will open and show
the available catalogs.
◦ Select the SDSS-DR12 catalog in the V – Combined data folder. A new
window will pop up.
◦ Select coverage, deselect in view and then click on Load. The footprint of
the SDSS-DR12 catalog will be loaded in the main window.
◦ Click on the “CDS/V/147/sdss12 MOC” panel. On top will appear the sky
coverage: 14520 sq. deg., 35.198% of the sky.
▪ How to obtain the region of the sky in common between SDSS DR12 and UKIDSS
Large Area Survey9 (LAS9):
◦ Repeat the same steps described to obtain the SDSS-DR12 MOC.
◦ Repeat the same steps to obtain the UKIDSS LAS9 MOC.
◦ Coverage →Logical operations. A new window will pop up.
◦ Select the CDS/V/147/sdss12 MOC and the CDS/II/319/las9 MOC and
choose Intersection. Click on Create. A new plane with the coverage of the
intersection of both MOCs will be loaded in the main window with a sky
coverage of 3654 sq. deg and 8.585% of the sky.
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Arithmetic operations between images.
◦ File → Open server selector. A new window will pop up.
◦ On the left hand side, select DSS label and choose DSS from ESO.
◦ Write LDS 1201 in the Target (ICRS, name) box and select DSS2-red –
POSS2UKSTU_Red in the drop down of Sky Survey. Click on Submit. The
corresponding image will be loaded in the main window.
◦ In the same Server selector window, select DSS1 – POSS1_Red and
UKSTU_Blue and click on Submit. The corresponding image will be loaded in
the main window.
◦ Image → Arithmetic operation. A new window will pop up.
◦ Select the previous loaded images and chose Subtraction. Then click on
Create. A new plane with the subtracted image will be loaded in the main
window. In this case, a high proper motion binary system lies in the center of
the image and the position of the components of the system at the epochs of
the selected images can be clearly seen.



RGB builder. Compose an RGB image with Aladin.
◦ Repeat the first four steps in the example above.
◦ Image → RGB image builder. A new window will pop up.
◦ Select the two previous loaded images and click on Create. A new image with
the resulting composed image will be loaded in the main window. In this case,
a high proper motion binary system lies in the center of the image and the
position of the components of the binary at the epochs of the selected images
can be clearly seen. NOTE: Although the RGB image builder is meant to
build a three color composed image (red, green and blue), it is also able to
build it with only two images, as noted in this example.



Blink/movie using images with Aladin.
◦ Repeat the first four steps in the example above.
◦ Image → Blink/movie generator. A new window will pop up.
◦ Select the previous loaded images and click on Create. A new plane with the
resulting movie will be loaded in the main window. On the top side of the
central panel there are control buttons for the movie to stop, play, move
forward/backward...
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Mosaic builder using images with Aladin.
◦ File → Open server selector. A new window will pop up.
◦ On the left hand side, select DSS label and choose DSS from ESO.
◦ Write 09 55 55.63423 +69 01 55.9684 in the Target (ICRS, name) box and
select DSS2-red – POSS2UKSTU_Red in the drop down of Sky Survey.
Change Width and Height to 5 arcmin. Click on Submit. The corresponding
image will be loaded in the main window.
◦ Repeat the previous step with the following coordinates and the same width
and height:
◦ 09 55 32.07698 +69 04 51.2255
◦ 09 55 08.96959 +69 02 57.2765
◦ 09 54 49.20075 +69 07 25.5246
◦ Image → Mosaic image builder. A new window will pop up.
◦ Select each of the loaded images and click on Create. A new plane with the
built mosaic will be loaded in the main window.



Sextractor: extract astrometry and photometry of a loaded image.
◦ File → Open server selector. A new window will pop up.
◦ On the left hand side, select DSS label and choose DSS from ESO.
◦ Write 00:10:15.02 -13:38:05.9 in the Target (ICRS, name) box and select
DSS2-red – POSS2UKSTU_Red in the drop down of Sky Survey. Click on
Submit. The corresponding image will be loaded in the main window.
◦ File → Open server selector. A new window will pop up.
◦ Select Tools → S-extractor on the top labels.
◦ Select the loaded image in Image reference and click on Submit. A new
plane with the extracted catalog will be loaded in the main window.



Display instruments Field of Views, useful to check whether one or another instrument’s
FoV covers the desired region.
◦ On top of the central panel, click “2MASS” just below the Command box. This
will load the HIPS 2MASS survey.
◦ Write SDSS J082322.44+530705.5 in the Command box to center the view
around that object.
◦ File → Load instrument FoV. A new window will pop up.
◦ Write SDSS J082322.44+530705.5 in the Target (ICRS, name) box and
select WFI. Click on Submit. A new plane with the WFI FoV will be loaded in
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the main window. Try to change the Angle in the FoV window to change the
rotation of the displayed FoV.


Many other funcionalities are available, like:
◦ Astrometric calibration
◦ Visualization of 2, 4, 9 or 16 panels (images) with the possibility of matching views
(unifying sizes and orientation)
◦ Load a macro script for repetitive tasks
◦ Generate a MOC from a loaded catalog
◦ …

NOTE: We refer the user to the F.A.Q section of Aladin for details on these and other functionalities. A
manual on the use of Aladin v10 is available here (in french).
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